Back to overview
Downtime

BEX Connect Restored

May 11, 2026 at 10:22am UTC
Affected services
bex-connect-beta.hexagon.icu

Resolved
May 11, 2026 at 10:02pm UTC

All services back online!

Updated
May 11, 2026 at 10:25am UTC

BEX Connect is back online and integrity verified

Created
May 11, 2026 at 10:22am UTC

On the evening of 10 May we experienced a hardware fault on one of our storage volumes, which took three services offline:

bex-connect-beta.hexagon.icu
bex-conenct.hexagon.icu

bex-connect-beta and live has been fully restored from our most recent verified backup and is operating normally.

Thank you for your patience.